[jira] [Updated] (CXF-8074) Use toolchain to build multi-release JARs

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (CXF-8074) Use toolchain to build multi-release JARs

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/CXF-8074?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Andriy Redko updated CXF-8074:
------------------------------
    Description:
Ideally, the multi-release JARs have to be build with multiple JDKs, for example if JDK is the latest one, pre-JDK13 and JDK13.
 Or, alternatively, by latest JDK13 twice, once for {{src/main/java}} (using{{ --release 8--}}) and once for {{src/main/java13}} (equivalent to {{-release 13}}).

The issue is with {{tools.jar}}, which is not in scope of javac's {{--release}} flag [1], it really needs to be built by JDK8. As the workaround, we could used {{-release 9}} to mitigate this issue (since {{tools.jar}} was merged into JDK9+) in a short term. The long term solution would be to use toolchain plugin.

[1] [https://bugs.openjdk.java.net/browse/JDK-8199325]

  was:
Ideally, the multi-release JARs have to be build with multiple JDKs, for example if JDK is the latest one, pre-JDK13 and JDK13.
 Or, alternatively, by latest JDK13 twice, once for {{src/main/java}} (using {{--release 8-}}) and once for {{src/main/java13}} (equivalent to {{-release 13}}).

The issue is with {{tools.jar}}, which is not in scope of javac's {{--release-}} flag [1], it really needs to be built by JDK8. As the workaround, we could used {{-release 9}} to mitigate this issue (since {{tools.jar}} was merged into JDK9+) in a short term. The long term solution would be to use toolchain plugin.

[1] [https://bugs.openjdk.java.net/browse/JDK-8199325]


> Use toolchain to build multi-release JARs
> -----------------------------------------
>
>                 Key: CXF-8074
>                 URL: https://issues.apache.org/jira/browse/CXF-8074
>             Project: CXF
>          Issue Type: Improvement
>            Reporter: Andriy Redko
>            Assignee: Andriy Redko
>            Priority: Major
>
> Ideally, the multi-release JARs have to be build with multiple JDKs, for example if JDK is the latest one, pre-JDK13 and JDK13.
>  Or, alternatively, by latest JDK13 twice, once for {{src/main/java}} (using{{ --release 8--}}) and once for {{src/main/java13}} (equivalent to {{-release 13}}).
> The issue is with {{tools.jar}}, which is not in scope of javac's {{--release}} flag [1], it really needs to be built by JDK8. As the workaround, we could used {{-release 9}} to mitigate this issue (since {{tools.jar}} was merged into JDK9+) in a short term. The long term solution would be to use toolchain plugin.
> [1] [https://bugs.openjdk.java.net/browse/JDK-8199325]



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)