[jira] [Updated] (CXF-7639) Support Servlet 4.0 API in OSGI manifest

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Updated] (CXF-7639) Support Servlet 4.0 API in OSGI manifest

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/CXF-7639?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Arnaud MERGEY updated CXF-7639:
-------------------------------
    Description:
Our OSGI application cannot be deployed on top of tomcat 9, because tomcat 9 exposes javax.servlet.xxx packages in V 4.0, and various bundles from cxf who depends of javax.servlet exclude 4.0 from their osgi manifest.

It seems Servlet 4.0 is already supported, so the simple fix for this only seems to include servlet 4.0 in range of supported version ( ** [0,4.1) instead of [0,4.0) in Import-Package)

  was:
Our OSGI application cannot be deployed on top of tomcat 9, because tomcat 9 exposes javax.servlet.xxx packages in V 4.0, and various bundles from cxf who depends of javax.servlet exclude 4.0 from their osgi manifest.

It seems Servlet 4.0 is already supported, so the simple fix for this seems to be only to include servlet 4.0 in range of supported version ( ** [0,4.1) instead of [0,4.0) in Import-Package)


> Support Servlet 4.0 API in OSGI manifest
> ----------------------------------------
>
>                 Key: CXF-7639
>                 URL: https://issues.apache.org/jira/browse/CXF-7639
>             Project: CXF
>          Issue Type: Bug
>          Components: OSGi
>    Affects Versions: 3.2.2
>            Reporter: Arnaud MERGEY
>            Priority: Major
>
> Our OSGI application cannot be deployed on top of tomcat 9, because tomcat 9 exposes javax.servlet.xxx packages in V 4.0, and various bundles from cxf who depends of javax.servlet exclude 4.0 from their osgi manifest.
> It seems Servlet 4.0 is already supported, so the simple fix for this only seems to include servlet 4.0 in range of supported version ( ** [0,4.1) instead of [0,4.0) in Import-Package)



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)