[jira] [Resolved] (CXF-8447) Content-Language always set to en_US

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (CXF-8447) Content-Language always set to en_US

Andriy Redko (Jira)

     [ https://issues.apache.org/jira/browse/CXF-8447?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Freeman Yue Fang resolved CXF-8447.
-----------------------------------
    Resolution: Information Provided

> Content-Language always set to en_US
> ------------------------------------
>
>                 Key: CXF-8447
>                 URL: https://issues.apache.org/jira/browse/CXF-8447
>             Project: CXF
>          Issue Type: Bug
>          Components: JAX-RS
>    Affects Versions: 3.3.1, 3.4.3
>            Reporter: Julien Greffe
>            Assignee: Freeman Yue Fang
>            Priority: Minor
>
> Hello,
> it seems there's an issue with header {{Content-Language}} which is always set to {{en_US}}.
> Here, entity is created with this default value:
> [https://github.com/apache/camel/blob/master/components/camel-cxf/src/main/java/org/apache/camel/component/cxf/jaxrs/DefaultCxfRsBinding.java#L255]
> And even when using {{language()}} on {{WebClient}}, value is always overriden here:
> [https://github.com/apache/cxf/blob/master/rt/rs/client/src/main/java/org/apache/cxf/jaxrs/client/WebClient.java#L1329]
>  
> Could you please provide a fix?



--
This message was sent by Atlassian Jira
(v8.3.4#803005)