[jira] [Resolved] (CXF-7372) Update Olingo dependency

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Resolved] (CXF-7372) Update Olingo dependency

JIRA jira@apache.org

     [ https://issues.apache.org/jira/browse/CXF-7372?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Dennis Kieselhorst resolved CXF-7372.
-------------------------------------
    Resolution: Fixed

I only updated to 2.0.8 for now.

As far as I understand OData 2 is incompatible with OData 4. So a simple update would break existing clients. To support both we need to add Olingo 4 in addition to Olingo 2 and either detect the OData version automatically or rename ODataParser to OData2Parser and add a new OData4Parser.

> Update Olingo dependency
> ------------------------
>
>                 Key: CXF-7372
>                 URL: https://issues.apache.org/jira/browse/CXF-7372
>             Project: CXF
>          Issue Type: Improvement
>          Components: JAX-RS
>    Affects Versions: 3.1.11
>            Reporter: Dennis Kieselhorst
>            Assignee: Dennis Kieselhorst
>            Priority: Minor
>             Fix For: 3.2.0
>
>
> Olingo 2.0.8 seems to work without problems.
> Olingo 4 would require changes as it uses OData 4.0.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)