[jira] [Commented] (CXF-8151) Upgrade to Bean Validation 2.x

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (CXF-8151) Upgrade to Bean Validation 2.x

Andriy Redko (Jira)

    [ https://issues.apache.org/jira/browse/CXF-8151?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17013901#comment-17013901 ]

Andriy Redko commented on CXF-8151:
-----------------------------------

[~deki] I have joined discussion [https://github.com/swagger-api/swagger-core/issues/3399] to bump Bean Validation to 2.0 for Swagger, it is a bummer for now, thanks!

> Upgrade to Bean Validation 2.x
> -------------------------------
>
>                 Key: CXF-8151
>                 URL: https://issues.apache.org/jira/browse/CXF-8151
>             Project: CXF
>          Issue Type: Task
>            Reporter: Andriy Redko
>            Assignee: Andriy Redko
>            Priority: Major
>             Fix For: 3.4.0
>
>
> CXF is still using the Bean Validation 1.x API whereas all modern implementations support 2.x mostly exlusively (Hibernate Validator 6.x, ...). We probably should consider moving the baseline to 2.x at least with CXF 3.4.0.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)