[jira] [Commented] (CXF-7910) Change JAX-WS javax to jakarta artifact dependencies

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (CXF-7910) Change JAX-WS javax to jakarta artifact dependencies

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/CXF-7910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16740014#comment-16740014 ]

Andriy Redko commented on CXF-7910:
-----------------------------------

Was able to reproduce the issue (on Java 11), seems to be related to javax.jws, haven't figured out the cause yet:
{noformat}
Message: Unable to resolve root: missing requirement [root] osgi.identity; osgi.identity=cxf-ws-discovery; type=karaf.feature; version=3.3.0.SNAPSHOT; filter:="(&(osgi.identity=cxf-ws-discovery)(type=karaf.feature)(version>=3.3.0.SNAPSHOT))" [caused by: Unable to resolve cxf-ws-discovery/3.3.0.SNAPSHOT: missing requirement [cxf-ws-discovery/3.3.0.SNAPSHOT] osgi.identity; osgi.identity=org.apache.cxf.services.ws-discovery.cxf-services-ws-discovery-service; type=osgi.bundle; version="[3.3.0.SNAPSHOT,3.3.0.SNAPSHOT]"; resolution:=mandatory [caused by: Unable to resolve org.apache.cxf.services.ws-discovery.cxf-services-ws-discovery-service/3.3.0.SNAPSHOT: missing requirement [org.apache.cxf.services.ws-discovery.cxf-services-ws-discovery-service/3.3.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=org.apache.cxf.ws.discovery.internal)(version>=3.3.0)(!(version>=4.0.0)))" [caused by: Unable to resolve org.apache.cxf.services.ws-discovery.cxf-services-ws-discovery-api/3.3.0.SNAPSHOT: missing requirement [org.apache.cxf.services.ws-discovery.cxf-services-ws-discovery-api/3.3.0.SNAPSHOT] osgi.wiring.package; filter:="(&(osgi.wiring.package=javax.jws)(version>=1.1.0)(!(version>=2.0.0)))"]]]
[ERROR] Repositories: {
[ERROR]  file:/Users/aredko/Workspaces2/prototypes/cxf/osgi/karaf/features/target/classes/features.xml
[ERROR]  mvn:org.apache.karaf.features/framework/4.2.2/xml/features
[ERROR]  mvn:org.apache.karaf.features/spring/4.2.2/xml/features
[ERROR]  mvn:org.apache.karaf.features/standard/4.2.2/xml/features
[ERROR]  mvn:org.ops4j.pax.cdi/pax-cdi-features/1.0.0/xml/features
[ERROR]  mvn:org.ops4j.pax.web/pax-web-features/6.0.2/xml/features
[ERROR]  mvn:org.ops4j.pax.web/pax-web-features/7.2.5/xml/features
[ERROR] }
[ERROR] Resources: {{noformat}

> Change JAX-WS javax to jakarta artifact dependencies
> ----------------------------------------------------
>
>                 Key: CXF-7910
>                 URL: https://issues.apache.org/jira/browse/CXF-7910
>             Project: CXF
>          Issue Type: Task
>          Components: JAX-WS Runtime
>            Reporter: Dennis Kieselhorst
>            Assignee: Dennis Kieselhorst
>            Priority: Minor
>             Fix For: 3.3.0
>
>
> See https://github.com/eclipse-ee4j/jax-ws-api/issues/46
> According to https://projects.eclipse.org/projects/ee4j.jaxws/ will be released on 2018-12-14.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)