[jira] [Commented] (CXF-7639) Support Servlet 4.0 API in OSGI manifest

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Commented] (CXF-7639) Support Servlet 4.0 API in OSGI manifest

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/CXF-7639?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16361257#comment-16361257 ]

ASF GitHub Bot commented on CXF-7639:
-------------------------------------

andymc12 commented on issue #380: [CXF-7639] Update dependency to servlet 4.0
URL: https://github.com/apache/cxf/pull/380#issuecomment-365023431
 
 
   There are two failures, but they definitely seem unrelated to the change in the OSGi export/import versions.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
[hidden email]


> Support Servlet 4.0 API in OSGI manifest
> ----------------------------------------
>
>                 Key: CXF-7639
>                 URL: https://issues.apache.org/jira/browse/CXF-7639
>             Project: CXF
>          Issue Type: Bug
>          Components: OSGi
>    Affects Versions: 3.2.2
>            Reporter: Arnaud MERGEY
>            Priority: Major
>
> Our OSGI application cannot be deployed on top of tomcat 9, because tomcat 9 exposes javax.servlet.xxx packages in V 4.0, and various bundles from cxf who depends of javax.servlet exclude 4.0 from their osgi manifest.
> It seems Servlet 4.0 is already supported, so the simple fix for this only seems to include servlet 4.0 in range of supported version ( ** [0,4.1) instead of [0,4.0) in Import-Package)



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)