[jira] [Comment Edited] (CXF-8335) CXF OpenAPI feature should not define servlet API dependency

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Comment Edited] (CXF-8335) CXF OpenAPI feature should not define servlet API dependency

Peter Seer (Jira)

    [ https://issues.apache.org/jira/browse/CXF-8335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17194323#comment-17194323 ]

Andriy Redko edited comment on CXF-8335 at 9/13/20, 2:29 PM:
-------------------------------------------------------------

[~jbonofre] the servlet-api dependency comes from Swagger OpenAPI v3 bundles, with 4.0 being the minimum version requirement. Karaf's `http` feature still relies on 3.1.0 specification ([https://github.com/apache/karaf/blob/master/pom.xml#L175):]

```

<servlet.spec.version>3.1.0</servlet.spec.version>

```

Excluding the override workaround I am wondering what are the options here for us:

 - use capabilities or standard features (if available) with Servlet 4.x?
  - only define Servlet API 4.x bundle if it is not defined yet? (I think this is what we have now)
  - any other option?

WDYT? Thanks.


was (Author: reta):
[~jbonofre] the servlet-api dependency comes from Swagger OpenAPI v3 bundles, I am wondering what are the options here for us:

 - use capabilities or standard features (if available)?
 - only define servlet API bundle if it is not defined yet?
 - any other option?

WDYT? Thanks.

> CXF OpenAPI feature should not define servlet API dependency
> ------------------------------------------------------------
>
>                 Key: CXF-8335
>                 URL: https://issues.apache.org/jira/browse/CXF-8335
>             Project: CXF
>          Issue Type: Bug
>          Components: OSGi
>    Affects Versions: 3.3.7
>            Reporter: Jean-Baptiste Onofré
>            Assignee: Andriy Redko
>            Priority: Major
>             Fix For: 3.3.8, 3.4.1
>
>
> OpenAPI feature should not define servlet API bundle as it can conflict with other features (and so we could have several resolution chain).



--
This message was sent by Atlassian Jira
(v8.3.4#803005)