[jira] [Comment Edited] (CXF-7910) Change JAX-WS javax to jakarta artifact dependencies

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[jira] [Comment Edited] (CXF-7910) Change JAX-WS javax to jakarta artifact dependencies

JIRA jira@apache.org

    [ https://issues.apache.org/jira/browse/CXF-7910?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16741328#comment-16741328 ]

Andriy Redko edited comment on CXF-7910 at 1/12/19 4:20 PM:
------------------------------------------------------------

Hey guys,

I think I found the issue, it comes from the dependency bump org.apache.servicemix.specs.jaxws-api-2.3 has, with respect to `javax.xml.soap`, it needs 1.4 while we install 1.3.

Import-Package: javax.xml.bind;version="[2.3,3)",javax.xml.bind.annota
  tion;version="[2.3,3)",javax.xml.namespace,javax.xml.soap;version="[1
  .4,2)",javax.xml.transform,javax.xml.transform.stream,org.osgi.framew
  ork,org.w3c.dom

Just to compare with org.apache.servicemix.specs.jaxws-api-2.2/2.9.0, we have javax.xml.soap;version="[1.3,2)":

Import-Package: javax.xml.bind;version="[2.2,3)",javax.xml.bind.annotati
  on;version="[2.2,3)",javax.xml.namespace,javax.xml.soap;version="[1.3,2
  )",javax.xml.transform,javax.xml.transform.stream,org.osgi.framework;ve
  rsion="[1.6,2)",org.w3c.dom

Karaf 4.2.2 has 1.3.0 as well, so we may need to add it to the `feature.xml`.

karaf@root()> exports | grep javax.xml.soap
javax.xml.soap                                                      | 1.3.0          | 0   | org.apache.felix.framework

[~deki] could you please update org.apache.servicemix.specs.saaj-api-1.3 ? We need 1.4 I think (I will try to do that if I have time). Thanks!


was (Author: reta):
Hey guys,

I think I found the issue, it comes from the dependency bump org.apache.servicemix.specs.jaxws-api-2.3 has, with respect to `javax.xml.soap`, it needs 1.4 while we install 1.3.

Import-Package: javax.xml.bind;version="[2.3,3)",javax.xml.bind.annota
 tion;version="[2.3,3)",javax.xml.namespace,javax.xml.soap;version="[1
 .4,2)",javax.xml.transform,javax.xml.transform.stream,org.osgi.framew
 ork,org.w3c.dom

Just to compare with org.apache.servicemix.specs.jaxws-api-2.2/2.9.0, we have javax.xml.soap;version="[1.3,2)":

Import-Package: javax.xml.bind;version="[2.2,3)",javax.xml.bind.annotati
 on;version="[2.2,3)",javax.xml.namespace,javax.xml.soap;version="[1.3,2
 )",javax.xml.transform,javax.xml.transform.stream,org.osgi.framework;ve
 rsion="[1.6,2)",org.w3c.dom

 

[~deki] could you please update org.apache.servicemix.specs.saaj-api-1.3 ? We need 1.4 I think. Thanks!

> Change JAX-WS javax to jakarta artifact dependencies
> ----------------------------------------------------
>
>                 Key: CXF-7910
>                 URL: https://issues.apache.org/jira/browse/CXF-7910
>             Project: CXF
>          Issue Type: Task
>          Components: JAX-WS Runtime
>            Reporter: Dennis Kieselhorst
>            Assignee: Dennis Kieselhorst
>            Priority: Minor
>             Fix For: 3.3.0
>
>
> See https://github.com/eclipse-ee4j/jax-ws-api/issues/46
> According to https://projects.eclipse.org/projects/ee4j.jaxws/ will be released on 2018-12-14.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)