[cxf-fediz] branch master updated: Systests for Jetty 9: switch to Tomcat 9

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[cxf-fediz] branch master updated: Systests for Jetty 9: switch to Tomcat 9

buhhunyx
This is an automated email from the ASF dual-hosted git repository.

buhhunyx pushed a commit to branch master
in repository https://gitbox.apache.org/repos/asf/cxf-fediz.git


The following commit(s) were added to refs/heads/master by this push:
     new 5c53d88  Systests for Jetty 9: switch to Tomcat 9
5c53d88 is described below

commit 5c53d88322345a9bf497d1e39d47eab7761e6e71
Author: Alexey Markevich <[hidden email]>
AuthorDate: Wed Sep 11 12:29:53 2019 +0300

    Systests for Jetty 9: switch to Tomcat 9
---
 systests/jetty9/pom.xml | 16 +++++++++-------
 1 file changed, 9 insertions(+), 7 deletions(-)

diff --git a/systests/jetty9/pom.xml b/systests/jetty9/pom.xml
index e4b63ca..d5a55bd 100644
--- a/systests/jetty9/pom.xml
+++ b/systests/jetty9/pom.xml
@@ -29,11 +29,6 @@
     <artifactId>fediz-systests-jetty9</artifactId>
     <name>Apache Fediz Systests for Jetty 9</name>
     <packaging>jar</packaging>
-    <properties>
-        <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
-        <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
-        <tomcat8.version>8.5.45</tomcat8.version>
-    </properties>
     <dependencies>
         <dependency>
             <groupId>org.eclipse.jetty</groupId>
@@ -92,13 +87,20 @@
         <dependency>
             <groupId>org.apache.tomcat.embed</groupId>
             <artifactId>tomcat-embed-core</artifactId>
-            <version>${tomcat8.version}</version>
+            <version>${tomcat.version}</version>
             <scope>test</scope>
         </dependency>
         <dependency>
             <groupId>org.apache.tomcat.embed</groupId>
             <artifactId>tomcat-embed-jasper</artifactId>
-            <version>${tomcat8.version}</version>
+            <version>${tomcat.version}</version>
+            <scope>test</scope>
+        </dependency>
+        <!-- Tomcat 9.x implements the Servlet 4.0 -->
+        <dependency>
+            <groupId>javax.servlet</groupId>
+            <artifactId>javax.servlet-api</artifactId>
+            <version>${servlet.version}</version>
             <scope>test</scope>
         </dependency>
          <dependency>