CXF related issues

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

CXF related issues

崔帅
Hello, I used your CXF plug-in for webService development. I successfully used JDK8 in Windows, but OpenJDK1.8 in Linux is always suggested (


 java.lang.NullPointerException at org.apache.cxf.common.util.Compiler.useJava6Compiler(Compiler.java:187). Is it because you don't support OpenJDk1.8 installed on Linux?
Your answer will be of great help to me, looking forward to your reply !

thank you!
Reply | Threaded
Open this post in threaded view
|

Re: CXF related issues

coheigea
Administrator
Hi,

What version of CXF are you using? If you are using an old version, please
try CXF 3.4.0 or 3.3.7 in case this issue has been fixed.

Colm.

On Fri, Sep 4, 2020 at 12:53 PM 崔帅 <[hidden email]> wrote:

> Hello, I used your CXF plug-in for webService development. I successfully
> used JDK8 in Windows, but OpenJDK1.8 in Linux is always suggested (
>
>
>  java.lang.NullPointerException at
> org.apache.cxf.common.util.Compiler.useJava6Compiler(Compiler.java:187). Is
> it because you don't support OpenJDk1.8 installed on Linux?
> Your answer will be of great help to me, looking forward to your reply !
>
> thank you!